Skip to main content

The Heartbleed Bug – What does it mean to me?

Heartbleed Icon
What’s all this about Heartbleed?

———————————
On April 7, researchers found a flaw in one of the tools used to secure internet traffic. That tool, called OpenSSL, is responsible for providing security on the internet. The bug allows an attacker to capture usernames, passwords, and pretty much any other information.

Why does this matter?

———————————
This is a big deal. Much of the internet relies on OpenSSL to protect secure traffic. At least 500,000 servers world-wide appear to be affected by the bug, and some personal computers and mobile devices are also affected. Until the bulk of affected computers are fixed, or “patched,” any secure site on the internet is potentially dangerous to visit.

What is Georgia Southern doing?

———————————
Georgia Southern IT Services has patched our vulnerable servers that are exposed to the internet. We’re also working on hunting down all internal servers that are still vulnerable, and will be getting those all patched very soon. We’re monitoring the situation, and we’ll keep the Georgia Southern community informed.

What should I do?

———————————
First off, don’t panic. While this is a serious vulnerability, security folks at Georgia Southern and around the world are working around the clock to reduce the risk. Nevertheless, there are some things you can do while the world catches up:

  • Avoid online banking and shopping for a few days, if you possibly can.
  • Don’t change your online banking password until your bank tells you that it’s OK; otherwise you may just be giving attackers your new password.
  • Be very suspicious of any emails asking you to change passwords.
  • Remember that legitimate Georgia Southern emails will never ask you to respond with sensitive information such as password, SSN, or bank account number.
  • Apply the latest security updates to your home and work computers, as well as to your mobile devices.

Last updated: 5/14/2015